母艦移管中・Gulpの実行する方式大分変わってたのでメモ

絶対つまずかないGulp入門(2018年版) – インストールとSassを使うまでの手順 – ICS MEDIA

絶対つまずかないGulp入門(2018年版) – インストールとSassを使うまでの手順


ちゃんと読まずにやってつまづいたよ

暫定メモ
package.jsonから不要なパッケージを消す
(効果があるのかはわからんがnodeのバージョンを9系に落とす)

ncu -u
npm install

エラーで
Tried to download(404): https://fsevents-binaries.s3-us-west-2.amazonaws.com/v1.1.2/fse-v1.1.2-node-v59-darwin-x64.tar.gz
がでたら
npm install -g node-gyp

npm install -D gulp
npx gulp

ちゃんとグローバルじゃなくてローカルにgulp入れるようにしたら動かんくなったwっておもったら実行がちゃう。
gulpじゃなくてnpx gulp。

あと全然関係ないけど、node-gypとか、Xcodeとか、いろんなものがバージョン足りないとか言われてかなりつまりつまりだったのでメモ。

npm install -g node-gyp
インスコ中になんかエラーでるなーと思ったらバージョンが古いって怒られてた

あとあまりにも古い古いってWarnが出るので、これ。

gulp packageの追加とupdate

ちょっともうちょっとちゃんお勉強しなければ。。
なんとなく通せるだけでぜんぜんわかってないわ〜。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください